Results 1 to 5 of 5

Thread: Error on check_wmi_plus building

  1. #1
    Junior Member
    Join Date
    Feb 2013
    Posts
    18

    Error on check_wmi_plus building

    Hello guys,

    I'm facing a problem on the installation of the check_wmi_plus plugin.
    I installed shinken 1.2.4 on debian squeeze using the tar.gz method (./ install -i)

    First i had a problem on MySQL_python which need an higher version of easy_install, i had to "easy_install -U distribute" and edit it's conf file to make it work.

    And now i'm stuck on check_wmi_plus, i run "USEPROXY=1 ./install -p check_wmi_plus" from the /root/shinken-1.2.4/ directory (this is where i extracted the tar.gz)

    Here is the log file
    Linking bin/shared/librpc_ndr_ntsvcs.so.0.0.1
    collect2: ld returned 1 exit status
    make[1]: *** [bin/shared/librpc_ndr_ntsvcs.so.0.0.1] Error 1
    make[1]: Leaving directory `/tmp/wmi-1.3.14/Samba/source'
    cd Samba/source ; \
    cp bin/winexe /bin ; \
    cp bin/wmic /bin ; \
    cp bin/shared/*async_wmi_lib.so.0* /lib/python
    cp: cannot stat `bin/shared/*async_wmi_lib.so.0*': No such file or directory
    make: *** [pywmi-installed] Error 1
    > Error while building wmic

    I found that Nicolas had the same bug : https://github.com/naparuba/shinken/issues/645#
    I tried to follow the instructions, run the install from the source (/root/shinken-1.2.4 in my case) and nothing

    Thanks
    Sébastien

  2. #2
    Junior Member
    Join Date
    Feb 2013
    Posts
    18

    Re: Error on check_wmi_plus building

    Any idea ?

  3. #3
    Senior Member
    Join Date
    Oct 2011
    Posts
    139

    Re: Error on check_wmi_plus building

    For the easy_install problem i'am curently thinking about using pip instead of easy install.

    Could you please write a bug report in github ? => https://github.com/naparuba/shinken/issues

    I will fix this asap

  4. #4
    Junior Member
    Join Date
    Feb 2013
    Posts
    18

    Re: Error on check_wmi_plus building

    Ok, i opened a ticket on github. https://github.com/naparuba/shinken/issues/750

    Should i also open one for the check_wmi_plus ?

  5. #5
    Junior Member
    Join Date
    Feb 2013
    Posts
    18

    Re: Error on check_wmi_plus building

    I close the topic.
    I fixed the problem by installing manually the wmi-1.3.16.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •