Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Unable to use skonf for managing Shinken

  1. #1
    Junior Member
    Join Date
    Dec 2012
    Posts
    4

    Unable to use skonf for managing Shinken

    Hi,

    I'm still on a "tour" flight of shinken, trying almost evrything. I tried to make skonf work but without any success ...
    To be very sure it was not due to other manipulations, I create a new fresh install of a new server (thanks to the virtualization !)
    OS : Debian 6, Shinken : 1.2.2 with install script.
    Evrything goes ok without any error.
    I can log in the Web UI. As wrote in the magical Hors-Serie Of Linux Mag, I verified the shinken-specific.cfg file for MongoDB : Ok
    I can log in skonf and do a discovery. It shows me my computers with services that absolutly the ones I was waiting for : Great ! tags are already setup

    I clic on "Validate" for each : Nothing
    Nothing in the logs files (/usr/local/shinken/var)
    And no new computer/services in the Shinken or Thruk interface.

    How can I find out what's going wrong, is there other log files ? I did not find more information on the Wiki (probably due to the fact that skonf is a new dev).

    Sincerely

    Jean-Roch

  2. #2
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: Unable to use skonf for managing Shinken

    Launch skonf in debug mode, the solution should be in the debug log
    No direct support by personal message. Please open a thread so everyone can see the solution

  3. #3
    Junior Member
    Join Date
    Dec 2012
    Posts
    4

    Re: Unable to use skonf for managing Shinken

    Hi,

    Done but nothing more in the arbitred.log :

    Code:
    2013-01-05 22:07:38,356 [1357420058] Info :  Using the local log file 'arbiterd.log'
    2013-01-05 22:07:38,370 [1357420058] Warning : Printing stored debug messages prior to our daemonization
    2013-01-05 22:07:38,370 [1357420058] Debug :  modulemanager file /usr/local/shinken/shinken/modulesmanager.pyc
    2013-01-05 22:07:38,371 [1357420058] Debug :  modulemanager absolute file /usr/local/shinken/shinken/modulesmanager.pyc
    2013-01-05 22:07:38,371 [1357420058] Debug :  Using modules path: /usr/local/shinken/shinken/modules
    2013-01-05 22:07:38,371 [1357420058] Debug :  Successfully changed to workdir: /usr/local/shinken/var
    2013-01-05 22:07:38,371 [1357420058] Debug :  Opening pid file: /usr/local/shinken/var/skonfd.pid
    2013-01-05 22:07:38,371 [1357420058] Debug :  Redirecting stdout and stderr as necessary..
    2013-01-05 22:07:38,373 [1357420058] Debug :  We are now fully daemonized :) pid=32218
    2013-01-05 22:07:38,421 [1357420058] Info :  Loading plugins: No module named pycurl
    2013-01-05 22:07:38,423 [1357420058] Info :  Loading plugins: No module named pycurl
    2013-01-05 22:07:38,449 [1357420058] Info :  [skonf] Allocating new skonfuiworker Worker: 0
    2013-01-05 22:07:38,457 [1357420058] Info :  [skonf] Allocating new skonfuiworker Worker: 1
    in the shinken-specific.cfg file :

    Code:
    define module {
     module_name Mongodb
     module_type mongodb
     uri mongodb://localhost/?safe=true
     database shinken
    }
    In the skonf.cfg fle :

    Code:
    # Module used by discovery to save objects
    discovery_backend_module=Mongodb
    So evrything seems OK, I can see hosts in the skonf, search for them (scan network), enable them (adding pack if needed) but nothing in Shinken.
    It seems that the information is well stored in Mongodb (skof can retreive the information from one log to another) but nothing in shinken, shinken does not seems to read information from Mongodb, I'm I right ?

    Sincerely,

    Jean-Roch

  4. #4
    Junior Member
    Join Date
    Jan 2013
    Posts
    2

    Re: Unable to use skonf for managing Shinken

    Hi @all,
    I'd like to push this Thread a bit, because I'm stuck now at the same point. I installed Shinken via the 10-Minutes auto-install Script and now it seems to be only a half-working install. I can discover Hosts in Skonf UI and add them, but they don't appear in the Shinken UI - even a restart of the Shinken deamons or the hole VM didn't help. I'm also missing a documentation about the concept behind Skonf in the official wiki.
    Any help is appreciated!

    My first impression of Shinken was very good, better than I had expected. Thanks to the Developers!

    Greetings from Munich,
    andreas5232

  5. #5
    Junior Member
    Join Date
    Jan 2013
    Posts
    6

    Re: Unable to use skonf for managing Shinken

    Hi,

    On my 1.2.2 Shinken installation, by default the arbiter do not read mongodb for configuration (the db used by Skonf).

    To enable this behavior, add the module "Mongodb" in the arbiter definition in shinken-specific.cfg :
    Code:
    define arbiter {
     modules Mongodb,PickleRetentionArbiter
     spare 0
     address localhost
     port 7770
     arbiter_name Arbiter-Master
    }
    Works for me.

  6. #6
    Junior Member
    Join Date
    Feb 2013
    Posts
    1

    Re: Unable to use skonf for managing Shinken

    Hi,

    I have the same problem.

    I follow the advice of francoislpj but now my arbiter don't start.

    The arbiter alarm
    Code:
    Starting arbiter:
    FAILED: Configuration is incorrect, sorry, I bail out (full output is in /tmp/bad_start_for_arbiter)
     failed!
    The shinken-specific.cfg
    Code:
    define arbiter {
     modules ,PickleRetentionArbiter,Mongodb
     spare 0
     address localhost
     port 7770
     arbiter_name Arbiter-Master
    }
    /tmp/bad_start_for_arbiter file
    Code:
    [1360142341] Error :  [host::10.190.245.148] max_check_attempts property not set
    [1360142341] Warning : The host 10.190.245.148 has no contacts nor contact_groups in (mongodb:mongodb://localhost/?safe=true:shinken)
    [1360142341] Error :  [items] In 10.190.245.148 is incorrect ; from mongodb:mongodb://localhost/?safe=true:shinken
    [1360142341] Error :  hosts conf incorrect!!
    I think it comes from the host i define before add the Mongodb module in shinken-specific.cfg. But how delete it ?

    If you have an advice

    Thanks a lot.

  7. #7
    Junior Member
    Join Date
    Jan 2013
    Posts
    2

    Re: Unable to use skonf for managing Shinken

    @francoislpj: Thank you very much! This helped me to get one step further.
    Now the Skonf UI seems to be half-working, because it doesn't add/active/disable hosts in realtime.
    But at the moment i'm not quite sure, whats causing this, so i'll debug some more to get an exact error message or something else, which helps fixing the problem.
    EDIT: If i'm in the skonf UI from time to time there appears a message saying "The UI backend is not available". Do you know more about this or how to debug or fix it?

    @balgrim: Maybe you need to remove the trailing "," from the Line with the Mongodb in it.
    Mine looks like this now:
    Code:
    define arbiter {
     modules Mongodb,PickleRetentionArbiter
     spare 0
     address localhost
     port 7770
     arbiter_name Arbiter-Master
    }
    Greetings from Germany!

  8. #8
    Administrator Frescha's Avatar
    Join Date
    May 2011
    Posts
    183

    Re: Unable to use skonf for managing Shinken

    You can ignore the message "The UI backend is not available".
    That's a bug. Sorry

    See You!

    Andreas / Ludwigshafen

  9. #9
    Junior Member
    Join Date
    Feb 2013
    Posts
    4

    Re: Unable to use skonf for managing Shinken

    Hi,

    Any news on this topic ?
    I get the same, I can use skonf for discover or edit hosts, but they are not loaded by shinken and invisible in shinken UI. Arbiter has the module Mongodb

  10. #10
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: Unable to use skonf for managing Shinken

    Sorry but from now I don't have time to work on skonf. Looks like a bug, so feel free to get as logs as you can an open a ticket, maybe another dev will have time to work on this part of the code.
    No direct support by personal message. Please open a thread so everyone can see the solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •