Results 1 to 7 of 7

Thread: Auto discovery fails with CentOS 5

Hybrid View

  1. #1

    Auto discovery fails with CentOS 5

    Hi all,

    I've been recently using Shinken and enjoying how powerful it is, please continue the great work!

    I am trying to use on a CentOS 5 VM (old, I know, maybe it's a good opportunity to upgrade...) but the discovery plugins are not working.

    Code:
    [root@labs028-nagios shinken]# ./libexec/nmap_discovery_runner.py -t localhost
    Got our target ['localhost']
    propose a tmppath /tmp/tmpMBYhue
    Launching command, sudo nmap localhost -sU -sT --min-rate 1000 --max-retries 0 -T4 -O --traceroute -oX /tmp/tmpMBYhue
    Try to communicate
    Error: the nmap return an error: 'nmap: unrecognized option `--min-rate'
    '
    [root@labs028-nagios shinken]#
    The nmap version is not THAT old, right?

    Code:
    Installed Packages
    Name    : nmap
    Arch    : x86_64
    Epoch   : 2
    Version  : 4.11
    (...)

    What am I missing here?

    Thanks!

  2. #2
    Administrator
    Join Date
    Dec 2011
    Posts
    278

    Re: Auto discovery fails with CentOS 5

    You need nmap 4.75 for that option.

    You can just strip out the min-rate and max-rate.

    xkilian

  3. #3
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,131

    Re: Auto discovery fails with CentOS 5

    Maybe a higher version is available in Centos repos like rpmforge, because without these options, nmap will be quite slow
    No direct support by personal message. Please open a thread so everyone can see the solution

  4. #4

    Re: Auto discovery fails with CentOS 5

    I gave up on CentOS 5 and deployed a brand new 6.3 (release few months ago).

    Still discovery doesn't work. It's a fresh install, both OS and Shinken.

    I've installed Shinken using the 10 minute install plus doing a ./install -p on all plugins and ./install -a on all addons. It just doesn't start any probing.

    What could I be doing wrong? Also any host that I manually add on Skonf is not being visible on the WebUI.

    Lots of small problems that really bother.
    I've used in a previous POC using Shinken+Centreon and it was very good, but I'd like to have this auto-discovery feature

    Thanks!

  5. #5
    Administrator
    Join Date
    Dec 2011
    Posts
    278

    Re: Auto discovery fails with CentOS 5

    Hello openglx,

    Nice to see you using Shinken.

    Step 1: I would suggest you download Shinken trunk instead of stock 1.2. This way you won't run into bugs that are already fixed for the planned 1.2.1 release. Trunk is safe to use until 1.2.1 is released.

    Step 2: I would suggest getting the discovery to work on the command line first:

    http://www.shinken-monitoring.org/wi...inken_advanced

    Step 3: I would suggest setting the shinken broker in debug mode to see why and where the SkonfUI is having a problem. You can also enable bottle.py, the integrated web server, debug mode (google it). SkonfUI usability is a bit hit and miss at this point unfortunately.

    This way we can identify the bug you are running into and get it fixed for the 1.2.1 release. Please try to put a bit of debug effort.

    I think Shinken is worth the effort.

    Cheers,

    xkilian

  6. #6

    Re: Auto discovery fails with CentOS 5

    Thanks for your tips, can you point me to where download the trunk? Would it be the https://github.com/naparuba/shinken repo?

  7. #7
    Administrator
    Join Date
    Dec 2011
    Posts
    278

    Re: Auto discovery fails with CentOS 5

    Yes, the link you have then just click on the download link. (It is on the right hand side)

    Or you can use git, if you are familiar with it and just clone the repository if you prefer.

    Cheers,

    xkilian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •