Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Dashbo Error: you didn't defined a WebUI module for saving user preference

  1. #11
    Junior Member
    Join Date
    Nov 2013
    Posts
    3

    Re: Dashbo Error: you didn't defined a WebUI module for saving user preference

    I just installed Shinken on CentOS 6, installed python-pymongo and mongodb with yum afterwards (should be a dependency of the Shinken RPM I think), but I still get that "You didn't define a WebUI module" thing.

    Any ideas?

  2. #12
    Administrator Frescha's Avatar
    Join Date
    May 2011
    Posts
    183

    Re: Dashbo Error: you didn't defined a WebUI module for saving user preference

    Do you have any log entries (Shinken & MongoDB)?

  3. #13
    Junior Member
    Join Date
    Nov 2013
    Posts
    3

    Re: Dashbo Error: you didn't defined a WebUI module for saving user preference

    @Frescha: thanks for investigating! I cannot see something special here.

    Shinken:

    ==> nagios.log <==
    [1384862489] Info : Shinken 1.4
    [1384862489] Info : Copyright (c) 2009-2011:
    [1384862489] Info : Gabes Jean (naparuba@gmail.com)
    [1384862489] Info : Gerhard Lausser, Gerhard.Lausser@consol.de
    [1384862489] Info : Gregory Starck, g.starck@gmail.com
    [1384862489] Info : Hartmut Goebel, h.goebel@goebel-consult.de
    [1384862489] Info : License: AGPL
    [1384862489] Info : [Broker] Using working directory: /var/lib/shinken
    [1384862489] Info : Stale pidfile exists (no or invalid or unreadable content). Reusing it.
    [1384862489] Info : Initializing Pyro connection with host:0.0.0.0 port:7772 ssl:False
    [1384862489] Warning : Printing stored debug messages prior to our daemonization
    [1384862494] Warning : [broker-1] Importing module openldap_ui: No module named ldap
    [1384862494] Warning : [All] The broker broker-1 seems to be down, I must re-dispatch its role to someone else.


    MongoDB:

    ==> mongodb.log <==
    Tue Nov 19 13:03:48.321 [initandlisten] MongoDB starting : pid=2040 port=27017 dbpath=/var/lib/mongodb 64-bit host=collector.corp.draeger.global
    Tue Nov 19 13:03:48.321 [initandlisten] db version v2.4.6
    Tue Nov 19 13:03:48.321 [initandlisten] git version: nogitversion
    Tue Nov 19 13:03:48.321 [initandlisten] build info: Linux buildvm-09.phx2.fedoraproject.org 3.10.9-200.fc19.x86_64 #1 SMP Wed Aug 21 19:27:58 UTC 2013 x86_64 BOOST_LIB_VERSION=1_41
    Tue Nov 19 13:03:48.321 [initandlisten] allocator: tcmalloc
    Tue Nov 19 13:03:48.321 [initandlisten] options: { bind_ip: "127.0.0.1", command: [ "run" ], config: "/etc/mongodb.conf", dbpath: "/var/lib/mongodb", fork: "true", journal: "true", logpath: "/var/log/mongodb/mongodb.log", nohttpinterface: "true", pidfilepath: "/var/run/mongodb/mongodb.pid", port: 27017, quiet: true, smallfiles: "true" }
    Tue Nov 19 13:03:48.335 [initandlisten] journal dir=/var/lib/mongodb/journal
    Tue Nov 19 13:03:48.335 [initandlisten] recover : no journal files present, no recovery needed
    Tue Nov 19 13:03:48.463 [initandlisten] waiting for connections on port 27017

  4. #14
    Administrator Frescha's Avatar
    Join Date
    May 2011
    Posts
    183

    Re: Dashbo Error: you didn't defined a WebUI module for saving user preference

    please have a look at your broker.log, maybe you can finde something like this

    Code:
    2013-11-03 18:47:39,471 [1383533259] Error :  Back trace of this remove: Traceback (most recent call last):
     File ".../shinken-master/shinken/modulesmanager.py", line 152, in try_instance_init
      inst.init()
     File "/var/lib/shinken/modules/Mongodb/module.py", line 79, in init
      self.con = Connection(self.uri)
     File "build/bdist.macosx-10.8-intel/egg/pymongo/connection.py", line 303, in __init__
      self.__find_node(seeds)
     File "build/bdist.macosx-10.8-intel/egg/pymongo/connection.py", line 666, in __find_node
      raise AutoReconnect(', '.join(errors))
    AutoReconnect: could not connect to skylab:27017: [Errno 8] nodename nor servname provided, or not known
    2013-11-03 18:47:39,472 [1383533259] Warning : The module 'Mongodb' failed to init, I will try to restart it later

  5. #15
    Junior Member
    Join Date
    Nov 2013
    Posts
    3

    Re: Dashbo Error: you didn't defined a WebUI module for saving user preference

    D'oh! I need a MongoDB server of course, it was not in the RPM dependency list. Now it's working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •