Results 1 to 3 of 3

Thread: service dependency does not work with dependent_servicegroup_name

  1. #1
    Junior Member
    Join Date
    Jul 2016
    Location
    San Francisco
    Posts
    2

    service dependency does not work with dependent_servicegroup_name

    Hello,

    I'm trying to evaluate Shinken in contrast to our current Nagios installation. I am running into an error when trying to load our Nagios 4 config. The error is
    FAILED: AttributeError: 'Servicedependency' object has no attribute 'dependent_service_description' (full output is in /tmp/bad_start_for_arbiter)
    . The following is a snippet from my config that shows how we get to this error. My questions: How do I fix this? What changes can i make to get this to work in Shinken? Is this an oversight in the app, and a bug that needs to be fixed?

    Code:
    define service {
        hostgroup_name         ams
        service_description    memory
        servicegroups          ams memory,memory
        use                    generic-service
        check_command          check_nrpe!check_mem
    }
    define servicegroup {
        servicegroup_name    ams memory
        alias                ams memory
    }
    define servicedependency {
        service_description              nrpe
        dependent_servicegroup_name      ams memory
        execution_failure_criteria       n
        notification_failure_criteria    p,c
    }
    Thanks!
    -david

  2. #2

    servicegroups not exploded

    It seems to me that shinken fails to explode groups for (at least) escalations and dependencies
    See also: https://github.com/naparuba/shinken/issues/1756

  3. #3
    Junior Member
    Join Date
    Jul 2016
    Location
    San Francisco
    Posts
    2
    Unfortunately that was a deal breaker for our Org. Sticking to Nagios w/ Saigon. Thanks for the bug report link!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •