Results 1 to 6 of 6

Thread: Error 500 on /dashboard/currently

  1. #1
    Junior Member
    Join Date
    Jun 2016

    Error 500 on /dashboard/currently

    Hi guys!

    I just installed Shinken 2.4.3 following the 10 minutes installation guide. Here, all command lines I used:

    rpm -ivh
    yum update
    yum install python-pip
    pip install --proxy http://user:Password@proxyserver:Port shinken
    pip install --proxy http://user:Password@proxyserver:Port cherrypy
    yum install nagios-plugins
    yum install python-crypto
    yum install mongodb mongodb-server
    yum install httpd-tools
    shinken --init
    pip install --proxy http://user:Password@proxyserver:Port -r
    shinken install webui2
    My Shinken works fine, I can access the WebUI and see my hosts, but I can't access the "currently" menu. I have the following error :

    Error: 500 Internal Server Error

    Sorry, the requested URL '' caused an error:

    Internal Server Error


    ZeroDivisionError('float division',)


    Traceback (most recent call last):
    File "/usr/bin/", line 862, in _handle
    File "/usr/bin/", line 1732, in wrapper
    rv = callback(*a, **ka)
    File "/var/lib/shinken/modules/webui2/", line 520, in lock_version
    return f(**args)
    File "/usr/bin/", line 3619, in wrapper
    return template(tpl_name, **tplvars)
    File "/usr/bin/", line 3595, in template
    return TEMPLATES[tplid].render(kwargs)
    File "/usr/bin/", line 3399, in render
    self.execute(stdout, env)
    File "/usr/bin/", line 3386, in execute
    eval(, env)
    File "/var/lib/shinken/modules/webui2/plugins/dashboard/views/currently.tpl", line 626, in <module>
    %pct_known_problems=round(100.0 * known_problems / s['nb_elts'], 2)
    ZeroDivisionError: float division

    I tried to replace files in /var/lib/shinken/modules/webui2 with the repo files, as I read here but it didn't work.

    Doesn't anyone has an idea of what I did wrong?

    Thanks in advance!

  2. #2
    Junior Member
    Join Date
    Jun 2016
    Nobody can help me? I'm really stuck with this problem...

  3. #3
    Join Date
    May 2013
    France - Valence
    Did not see your post before ... sorry.

    1/ Have you declared any hosts and services to monitor in your Shinken ?

    2/ Please try with the source code in the develop branch of the repo

    Best regards, Fred.

  4. #4
    Junior Member
    Join Date
    Jun 2016
    No problem, thank you for your answer!

    Yes I have 4 hosts monitored, my localhost plus 3 routers/switches. I only perform a check_alive on them. I tried another check with check_snmp, but I still had the same problem.

    I also tried to re install Shinken from sources, but I have the exact same error 500...

  5. #5
    Junior Member
    Join Date
    Jun 2016
    I tried few things like switch SELinux into permissive mode but I'm still stuck with this problem, if somebody knows how to fix it

  6. #6
    Junior Member
    Join Date
    Jul 2016

    I have the same Error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts