Results 1 to 5 of 5

Thread: Email notifications not being sent

  1. #1
    Junior Member
    Join Date
    Nov 2015
    Posts
    3

    Question Email notifications not being sent

    Hello!
    I recently installed Shinken (on a debian 7 virtual machine) and just want to perform some basic ping checks. I managed to get it to the point where everything is working fine in shinken webui. The problem I am facing is that emails are not leaving the Shinken machine because of the malformed sender address "shinken@shinken". Its driving me crazy as I can't find where to set the FROM email address.
    The command that generates notification:
    Code:
    /var/lib/shinken/libexec/notify_by_email.py -n host -S localhost -r me@receiver.com -f txt -c "PROBLEM,,problemhost,,10.5.6.7,,Fri 30 Oct 23:54:59 EDT 2015" -o "problemhost,,DOWN,,31h 04m 59s"
    Postque -p returns this:
    Code:
    mail.receiver.com[123.32.13.34] said: 450 4.1.8 <shinken@shinken>: Sender address rejected: Domain not found (in reply to RCPT TO command))
    Thank you for your answer and keep on the good work!

    Jernej

  2. #2
    Junior Member
    Join Date
    Nov 2015
    Posts
    3
    This workaround helped to get my email notifications working: http://semi-legitimate.com/blog/item...ess-in-postfix

  3. #3
    Junior Member
    Join Date
    Nov 2015
    Posts
    5
    Hi

    I have same problem, Host Notification is getting logged in Scheduler "please find below is the same" but not receiving any mail.

    [1449648495] HOST NOTIFICATION: admin;dlink;DOWN;notify-host-by-email;PING CRITICAL - Packet loss = 100%

    [1449648497] WARNING: [Shinken] The notification command '/var/lib/shinken/libexec/notify_by_email.py -n host -S localhost -r deepak.m@onze.in -f html -c "PROBLEM,,dlink,,192.168.2.2,,Wed 09 Dec 13:38:15 IST 2015"" -o ""DOWN,,01h 44m 59s"' raised an error (exit code=1): 'Traceback (most recent call last):'

    Some one please help.

    Thank you in advance

  4. #4
    Junior Member
    Join Date
    Nov 2015
    Posts
    5
    Can some one please help me out with this issue.

  5. #5
    Junior Member
    Join Date
    Nov 2015
    Posts
    3
    Quote Originally Posted by Deepak View Post
    Can some one please help me out with this issue.
    Hi deepak. Did you solve the issue? Maybe you missed the installation of the html module:
    Code:
    pip install html

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •