Hi, I'm currently trying to set up openldap authentication for webUI2 in shinken, and I can't understand why authentication fails.

My current settings are :

for : modules/auth_active_directory.cfg
Code:
define module {
    module_name     ActiveDir_UI
    module_type     ad_webui
    ldap_uri        ldaps://ldap.pseudo.moi:636
    username        USERNAME
    password        PASSWORD
    basedn          dc=pseudo,dc=moi

    # For mode you can switch between ad (active dir)
    # and openldap
    mode	    openldap
}
for : modules/webui2.cfg
Code:
   ## Declare the list of external modules
   modules ActiveDir_UI
for : brokers/broker-master.cfg
Code:
    # Comma separated list of modules
    modules		webui2

modules have been installed by running:
Code:
shinken install webui2
shinken install auth-active-directory
logs obtained through /var/log/shinken/broker-debug.log in debug mode :

Code:
[1537113307] INFO: [broker-master] [WebUI]  user 'pseudo' is signing in ...
[1537113307] INFO: [broker-master] [WebUI] Checking authentication for user: pseudo
[1537113307] INFO: [broker-master] [WebUI] Requesting authentication for user: pseudo
[1537113307] INFO: [broker-master] [WebUI] Authenticating user 'pseudo'
[1537113307] INFO: [broker-master] [WebUI] Authenticating user 'pseudo' with ActiveDir_UI
[1537113307] DEBUG: [broker-master] [Active Directory UI] Trying to auth by ldap with user pseudo
[1537113307] DEBUG: [broker-master] [WebUI - datamanager] get_contact, name: pseudo, user: None
[1537113307] DEBUG: [broker-master] [WebUI - datamanager] get_contacts, name: pseudo
[1537113307] DEBUG: [broker-master] [WebUI - datamanager] got 2 contacts
[1537113307] WARNING: [broker-master] [Active Directory UI] AD/Ldap: invalid user pseudo (not found)
[1537113307] INFO: [broker-master] [WebUI] Internal htpasswd authentication
[1537113307] INFO: [broker-master] [WebUI] Internal alignak backend authentication
[1537113307] INFO: [broker-master] [WebUI] Internal contact authentication
[1537113307] INFO: [broker-master] [WebUI-auth-cfg-password] Authenticating user 'pseudo'
[1537113307] DEBUG: [broker-master] [WebUI - datamanager] get_contact, name: pseudo, user: None
[1537113307] DEBUG: [broker-master] [WebUI - datamanager] get_contacts, name: pseudo
[1537113307] DEBUG: [broker-master] [WebUI - datamanager] got 2 contacts
[1537113307] ERROR: [broker-master] [WebUI-auth-cfg-password] You need to have a contact having the same name as your user: pseudo
[1537113307] WARNING: [broker-master] [WebUI] The user 'pseudo' has not been authenticated.
[1537113307] DEBUG: [broker-master] [WebUI] get_url for 'GetLogin'
[1537113307] WARNING: [broker-master] [WebUI]  user 'pseudo' access denied, redirection to: /user/login?error=Invalid user or Password
[1537113307] DEBUG: [broker-master] [WebUI] get_url for 'GetLogin'
[1537113307] DEBUG: [broker-master] [WebUI] login_required, requested URL: /user/login
[1537113307] DEBUG: [broker-master] [WebUI] get_url for 'Logout'
[1537113307] DEBUG: [broker-master] [WebUI] user login request, remote user enabled: 0: X_REMOTE_USER
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Referer = http://pseudo.moi:7767/user/login?er...0or%20Password
[1537113307] DEBUG: [broker-master] [WebUI] X request header: User-Agent = Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.92 Safari/537.36
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Connection = keep-alive
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Host = pseudo.moi:7767
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Upgrade-Insecure-Requests = 1
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Cache-Control = max-age=0
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Accept = text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Accept-Language = en-US,en;q=0.9,es;q=0.8,fr;q=0.7
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Accept-Encoding = gzip, deflate
[1537113307] DEBUG: [broker-master] [WebUI] X request header: Cookie = sidebar_collapsed=false; user_session="!HSjFCrETiGCuPouXukUPgg==?gAJVDHVzZXJfc2Vzc2lvbnEBiYZxAi4="
[1537113307] WARNING: [broker-master] [WebUI] login page with error message: Invalid user or Password
[1537113308] DEBUG: [broker-master] Debug perf: ping [args:9.05990600586e-06] [aqu_lock:1.90734863281e-06][calling:5.96046447754e-06] [json:1.90734863281e-05] [global:3.60012054443e-05]
[1537113308] DEBUG: [broker-master] Debug perf: get_external_commands [args:6.91413879395e-06] [aqu_lock:9.53674316406e-07][calling:3.21865081787e-05] [json:1.38282775879e-05] [global:5.3882598877e-05]
[1537113308] DEBUG: [broker-master] [Broks] Begin Loop: managing queue broks [0]
[1537113308] DEBUG: [broker-master] [Broks] External Queue len (webui2): 0
[1537113308] DEBUG: [broker-master] 0 Broks get in 0.00300478935242
[1537113308] DEBUG: [broker-master] 0 Broks get in 0.00318503379822
[1537113308] DEBUG: [broker-master] 0 Broks get in 0.00312805175781
[1537113308] DEBUG: [broker-master] 0 Broks get in 0.00196290016174
[1537113308] DEBUG: [broker-master] [WebUI] manage_brok_thread got 0 broks, queue length: 0
[1537113308] DEBUG: [broker-master] [WebUI] time to manage 0 broks (time 0.022s)
[1537113308] DEBUG: [broker-master] [Broks] Time to send [0] broks to module ([0.001] secs)
[1537113308] DEBUG: [broker-master] [stats] nb object get control queues of external module [0]
[1537113308] DEBUG: [broker-master] [stats] broks done this loop 0/0
[1537113309] DEBUG: [broker-master] Debug perf: ping [args:1.00135803223e-05] [aqu_lock:1.90734863281e-06][calling:4.05311584473e-06] [json:2.00271606445e-05] [global:3.60012054443e-05]
[1537113309] DEBUG: [broker-master] Debug perf: get_external_commands [args:7.86781311035e-06] [aqu_lock:2.14576721191e-06][calling:3.981590271e-05] [json:1.81198120117e-05] [global:6.79492950439e-05]
[1537113309] DEBUG: [broker-master] [Broks] Begin Loop: managing queue broks [0]
[1537113309] DEBUG: [broker-master] [Broks] External Queue len (webui2): 0
[1537113309] DEBUG: [broker-master] 0 Broks get in 0.00225400924683
[1537113309] DEBUG: [broker-master] 0 Broks get in 0.00206804275513
[1537113309] DEBUG: [broker-master] 0 Broks get in 0.00175714492798
[1537113309] DEBUG: [broker-master] 0 Broks get in 0.00146293640137
[1537113309] DEBUG: [broker-master] [WebUI] manage_brok_thread got 0 broks, queue length: 0
[1537113309] DEBUG: [broker-master] [WebUI] time to manage 0 broks (time 0.0028s)
[1537113309] DEBUG: [broker-master] [Broks] Time to send [0] broks to module ([0.001] secs)
[1537113309] DEBUG: [broker-master] [stats] nb object get control queues of external module [0]
[1537113309] DEBUG: [broker-master] [stats] broks done this loop 0/0
No logs are received from ldap. I can ldapsearch from shinken machine to ldap machine

Any idea to help me ?