Results 1 to 2 of 2

Thread: Using BS3 webUI with standard 2.4 Shinken

  1. #1
    Junior Member
    Join Date
    Jul 2015

    Using BS3 webUI with standard 2.4 Shinken

    Hi all,

    I have just installed a fresh Shinken 2.4.0, and added the webui with 'shinken install webui'
    I need the History tab and saw that 'shinken install' grab an old copy of webui, without the latest functionnalities.
    I followed the instruction to get the BS3 branch (git clone -b bs3 && shinken install --local mod-webui).

    I now have the nicest webui of the world, but got an exception in the problems tab :

    Sorry, the requested URL '' caused an error:
    Internal Server Error
    AttributeError("'Webui_broker' object has no attribute 'get_graph_uris'",)
    Traceback (most recent call last):
      File "/var/lib/shinken/modules/webui/lib/", line 862, in _handle
      File "/var/lib/shinken/modules/webui/lib/", line 1732, in wrapper
        rv = callback(*a, **ka)
      File "/var/lib/shinken/modules/webui/", line 392, in lock_version
        return f(**args)
      File "/var/lib/shinken/modules/webui/lib/", line 3619, in wrapper
        return template(tpl_name, **tplvars)
      File "/var/lib/shinken/modules/webui/lib/", line 3595, in template
        return TEMPLATES[tplid].render(kwargs)
      File "/var/lib/shinken/modules/webui/lib/", line 3399, in render
        self.execute(stdout, env)
      File "/var/lib/shinken/modules/webui/lib/", line 3386, in execute
        eval(, env)
      File "/var/lib/shinken/modules/webui/plugins/problems/views/problems.tpl", line 82, in <module>
        %graphs = app.get_graph_uris(pb, now-4*3600, now)
    AttributeError: 'Webui_broker' object has no attribute 'get_graph_uris'
    I suspect my broker not being the latest version and not having the get_graph_uris attribute, but cannot find where the broker version is...
    Has someone already got this issue ? How to know the broker version ?

    Thank for any help

  2. #2
    Junior Member
    Join Date
    Aug 2015

    I had the same problem. To fix, you need to edit /etc/shinken/modules/webui.cfg :

    ## Modules for WebUI
       # - auth-htpasswd         = Use an htpasswd file for auth backend.
       # - auth-active-directory = Use AD for auth backend (and retrieve photos).
       # - auth-cfg-password     = Use the password set in Shinken contact for auth.
       # - auth-ws-glpi          = Use the Glpi Web Services for user authentication
       # - ui-pnp                = Use PNP graphs in the UI.
       # - ui-graphite           = Use graphs from Graphite time series database.
       # - mongodb               = Save user preferences to a Mongodb database
       # - SQLitedb              = Save user preferences to a SQLite database
       modules            auth-cfg-password,ui-graphite,SQLitedb
    In my case i remove "auth-ws-glpi" and add SQLitedb. Maybe you use mongodb so adapt my conf

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts