Results 1 to 3 of 3

Thread: Services disappearing from thruk on config change and arbiter restart

  1. #1
    Junior Member
    Join Date
    Jun 2015
    Posts
    2

    Services disappearing from thruk on config change and arbiter restart

    Hi everyone,

    We're having a strange issue on our current production Shinken servers. When restarting the arbiter to take into account a configuration modification, some services might not show up on Thruk. If I restart the arbiter a second time, all is well.

    I manages to double check that:
    In the arbiterd.log, I always get the right number of services ("[1435131526] INFO: [Shinken] Checked 1238 services")
    If I dump the shinken configuration as a json file to parse it myself, I do get the right service count each time.

    It seems only Thruk/Livestatus has issues

    Version information:
    Shinken 2.4
    Thruk 1.88-4
    Latest livestatus module

    Some context:
    We have 4 realms, for 4 sites: new-york, frankfort, amazon and paris. each site has a reactionner, a receiver, a poller and a scheduler. Paris also has a broker and the arbiter.
    This behavior is only observed on new-york frankfort and amazon. Never on paris.

    Is this a known issue ? What information can I provide to help ?
    Note: I'm not afraid of getting my hands in the code a bit.

    Cheers,
    --
    Marc-Olivier Barre
    SN-Architecture

  2. #2
    Junior Member
    Join Date
    Jun 2015
    Posts
    2
    A little more details in hope for an answer... it appears our ite in Paris might also be suffereing from the same thing. So, since our migration to 2.4 we need to restart the arbiter twice, otherwise a few services will not appear on livestatus, and I'm assuming that alarms and checks are probably also down for those services.

    Is this the right place for a bug report ? Do we need to subscribe a support contract ?

    Regards,
    Marco.

  3. #3
    Junior Member
    Join Date
    Sep 2015
    Location
    Paris
    Posts
    5
    Any news about this ?
    We encounter the same bug here. Just one realm, 1 active broker and 1 spare broker.
    From the arbiter logd:
    [1447752840] INFO: [Shinken] Checked 12630 services.
    From thruk or directly with a livestatus query, only 9579 services viewed.
    Regards,
    FF

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •