Hello,

I'm new to shinken, make a test install on a raspbian. As rasbian/wheezy miss shinken, I did a pip install (2.2), install a few shinken modules like linux-snmp, sqlitedb.
Web interface is running well.

Now I want to add perfdata. Give a try to pnp4nagios. basically, installed like that
Code:
sudo apt-get -y install pnp4nagios-web
sudo update-rc.d npcd defaults
sudo perl -pi -e 's@http://YOURSERVERNAME/pnp4nagios/@http://'$ipaddr'/pnp4nagios/@;' /etc/shinken/modules/ui-pnp.cfg
sudo perl -pi -e 's@/usr/local/pnp4nagios/etc/npcd.cfg@/etc/pnp4nagios/npcd.cfg@' /etc/shinken/modules/npcdmod.cfg
sudo perl -pi -e 's@^RUN="no"@RUN="yes"@' /etc/default/npcd
sudo perl -pi -e 's@= nagios@= shinken@' /etc/pnp4nagios/npcd.cfg
sudo setfacl -R -m "u:shinken:rwx" -- /var/spool/pnp4nagios/ /var/lib/pnp4nagios /var/log/pnp4nagios
sudo service npcd restart
also added 'process_perf_data 1' to host/service

I checked both
http://www.shinken-monitoring.org/wiki/use_with_pnp
http://shinken.readthedocs.org/en/la...ation/pnp.html
and few posts like
http://forum.shinken-monitoring.org/...nken-2-0/page2

I have a link to pnp4nagios (no direct link on each source) but all is empty
Code:
Please check the documentation for information about the following error.

perfdata directory "/var/lib/pnp4nagios/perfdata/" is empty. Please check your Nagios config. Read FAQ online
Code:
$ sudo tail /var/log/pnp4nagios/npcd.log
[03-05-2015 21:22:37] NPCD: ThreadCounter 0/5 File is ..
[03-05-2015 21:22:37] NPCD: No more files to process... waiting for 15 seconds
[03-05-2015 21:22:52] NPCD: Found 2 files in /var/spool/pnp4nagios/npcd/
[03-05-2015 21:22:52] NPCD: ThreadCounter 0/5 File is .
[03-05-2015 21:22:52] NPCD: ThreadCounter 0/5 File is ..
[03-05-2015 21:22:52] NPCD: No more files to process... waiting for 15 seconds
[03-05-2015 21:23:07] NPCD: Found 2 files in /var/spool/pnp4nagios/npcd/
[03-05-2015 21:23:07] NPCD: ThreadCounter 0/5 File is .
[03-05-2015 21:23:07] NPCD: ThreadCounter 0/5 File is ..
[03-05-2015 21:23:07] NPCD: No more files to process... waiting for 15 seconds
$ sudo grep -ri '(npc|pnp)' /var/log/shinken/*
$
$ sudo find /var/lib/pnp4nagios/
/var/lib/pnp4nagios/
/var/lib/pnp4nagios/perfdata
$
webui.conf
Code:
$ egrep -v '^[ ]*[#;]' /etc/shinken/modules/webui.cfg 
define module {
    module_name         webui
    module_type         webui
    host                0.0.0.0     ; All interfaces = 0.0.0.0
    port                7767
    auth_secret         xxx   ; CHANGE THIS or someone could forge cookies
    allow_html_output   1       ; Allow or not HTML chars in plugins output.
    max_output_length   1024     ; Maximum output length for plugin output in webui
    manage_acl          1       ; Use contacts ACL. 0 allow actions for all.
    play_sound          0       ; Play sound on new non-acknowledged problems.
    login_text          Welcome on Shinken WebUI    ; Text in the login form.

    modules             auth-cfg-password,SQLitedb,ui-pnp

}
and broker
Code:
$ egrep -v '(^[ ]*[#;]|^$)' /etc/shinken/brokers/broker-master.cfg 
define broker {
    broker_name     broker-master
    address         localhost
    port            7772
    spare           0
    manage_arbiters     1   ; Take data from Arbiter. There should be only one
    manage_sub_realms   1   ; Does it take jobs from schedulers of sub-Realms?
    timeout             3   ; Ping timeout
    data_timeout        120 ; Data send timeout
    max_check_attempts  3   ; If ping fails N or more, then the node is dead
    check_interval      60  ; Ping node every N seconds
    modules     webui,npcdmod
    use_ssl               0
    hard_ssl_name_check   0
    
    realm   All
}
Thanks a lot for any help