Results 1 to 4 of 4

Thread: Notifications flooding

  1. #1
    Junior Member
    Join Date
    Jul 2014
    Posts
    5

    Notifications flooding

    Hello,

    We encounter some issue this weekend, Shinken has started to send notification every ~5-10 seconds for each host & service.
    In few hours, we receive 150K emails in 10 differents mailbox...

    We disabled ssmtp to avoid bandwith issue and changed the scheduler level log to "debug".

    I can see message like this every 5 seconds:

    2014-12-01 10:38:40,229 [1417426720] Debug : Nb checks/notifications/event send: 12
    2014-12-01 10:38:41,247 [1417426721] Debug : Checks: total 1871, scheduled 1859, inpoller 12, zombies 0, notifications 21
    2014-12-01 10:38:42,267 [1417426722] Debug : Checks: total 1871, scheduled 1853, inpoller 18, zombies 0, notifications 21
    I also have these messages:


    2014-12-01 10:52:43,683 [1417427563] Warning : 17 actions never came back for the satellite 'reactionner-master'. I reenable them for polling


    I saw a previous similar post with old version of Shinken here: http://forums.monitoring-fr.org/index.php?topic=5717.0

    On our side, we don't change any settings on hosts, services, or notifications.

    Could you please give me some advice ?

  2. #2
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: Notifications flooding

    Which shinken version?
    No direct support by personal message. Please open a thread so everyone can see the solution

  3. #3
    Junior Member
    Join Date
    Jul 2014
    Posts
    5

    Re: Notifications flooding

    [quote author=naparuba link=topic=1943.msg7834#msg7834 date=1417507439]
    Which shinken version?
    [/quote]

    Hello,

    We're using Shinken v2.0.3

  4. #4
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: Notifications flooding

    Can you give a try with the lastest master version (soon 2.2 RC1 version). We fix some bugs like this lately.
    No direct support by personal message. Please open a thread so everyone can see the solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •