Results 1 to 4 of 4

Thread: stalking_options seemingly no longer working

  1. #1
    Junior Member
    Join Date
    Oct 2013
    Posts
    5

    stalking_options seemingly no longer working

    Greetings,

    I am running Shinken 2.0.3 from an upgraded system which ran 1.4. I was using stalking_options to check our storage utilization on a twice day basis then forwarding the data into Splunk for graphing. I have since replaced our storage and disabled the check. I just re-enabled the check, but it doesn't seem that the 'stalking_option' logs into the nagios.log. Has the stalking_option been deprecated in newer versions of Shinken. I can see state changes being logged, but as a storage utilization check would not normally have a state change it is not logged. I had used the original Shinken configurations for the 2.0.3 system as I had built on the 1.4 system. I appreciate any help offered.

  2. #2
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: stalking_options seemingly no longer working

    Nop there is no such deprecation. Can you try by increasing your log level verbosity? (some 2.0 version got an issue there).
    No direct support by personal message. Please open a thread so everyone can see the solution

  3. #3
    Junior Member
    Join Date
    Oct 2013
    Posts
    5

    Re: stalking_options seemingly no longer working

    Naparuba,

    Thanks for looking into the issue. I will try the log level verbosity.

    I'd like to add additional information in the meantime:

    define command{
    command_name check_netapp_vol_ssh
    command_line ssh $HOSTADDRESS$ vol show -volume $ARG1$ -fields filesystem-size,used | grep $ARG1$
    }

    define service{
    use twice-a-day-service ; Name of service template to use
    host_name netapp-cluster
    service_description Netapp Homes Volume Check
    check_command check_netapp_vol_ssh!homesvol
    }

    define service{
    name twice-a-day-service ; The name of this service template
    use generic-service ; The 'name' of this service template
    process_perf_data 0 ; Do not process performance data
    retry_interval 0 ; Schedule host check retries at 1 minute intervals
    normal_check_interval 720 ; Check the service every 5 minutes under normal conditions
    max_check_attempts 0 ; Check each Linux host 10 times (max)
    stalking_options o ; Use Stalking to log check for every state
    register 0 ; DONT REGISTER THIS DEFINITION - ITS NOT A REAL SERVICE, JUST A TEMPLATE!
    }

    I changed the 'stalking_options' to from 'o,w,u,c' to simply 'o'. A manual check gives me the following information:

    windows homesvol 375GB 269.8GB

    The data I seek is simply the output of an an ssh command. Under Addition Information I have nothing under "Performance Data". If performance data is what is being sent via the stalking options then that would explain my issue. Any ideas?

    I could write a plugin that places the output in performance data instead to check if that is my problem.

  4. #4
    Junior Member
    Join Date
    Oct 2013
    Posts
    5

    Re: stalking_options seemingly no longer working

    It seems that the missing perf data might be the key to the stalking option. I enabled the original check on my older storage and set the stalking option and after I forced a check I received the following in my increased verbosity schedulerd.log

    2014-11-05 18:17:55,824 [1415179075] Info : Stalking Netappst Root Volume Check: OK - vol0 usage: 1.50 / 133.95 GB (1.12% full), 6235 / 6709205 files (0.09%)

    OK. I will write a plugin to do provide performance data along with standard output and see if that works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •