Results 1 to 5 of 5

Thread: Can't make shinken to send notifications

  1. #1

    Can't make shinken to send notifications

    Hello, I use shinken 0.8.5 from omd 0.52 on debian 6 x64.

    Here is my contacts definitions :
    Code:
    define contact {
      contact_name          omdadmin
      alias              OMD Test User
      email              root@localhost
      host_notification_commands   omd-dummy
      host_notification_period    none
      host_notification_options    n
      service_notification_commands  omd-dummy
      service_notification_period   none
      service_notification_options  n
    }
    
    define contact{
        contact_name          lminoza
        alias              Landry MINOZA
        email              landry.minoza@mydomain
        host_notification_commands   host-notify-by-email
        host_notification_period    24x7
        host_notification_options    d,u,r,f,s
        service_notification_commands  service-notify-by-email
        service_notification_period   24x7
        service_notification_options  w,u,c,r,f,s
    }
    
    define contactgroup {
      contactgroup_name        omd
      alias              OMD Test Users
      members             omdadmin,lminoza
    }

    My base host template associates the group omd with all my hosts. All seams ok in the object_cache and using the config tool of thruk but no notifications are send.
    They do not appear in the notification list of thruk, nothing about notifications is logged. I do not understand where I can have make an error.

    The only thing I can suspect is this repeated line in the log :
    Code:
    [1325148446] Warning : 26 actions never came back for the satellite 'integ-reactionner'. I'm reenable them for polling
    I tried to launch the reactionner in debug mode, and got this:
    Code:
    We are now fully daemonized :) pid=27339
    modulemanager file /omd/sites/integ/lib/shinken/shinken/modulesmanager.py
    modulemanager absolute file /omd/sites/integ/lib/shinken/shinken/modulesmanager.py
    Using modules path : /omd/sites/integ/lib/shinken/shinken/modules
    Waiting for initial configuration
    ...1325147582 DBG: the arbiter ask me what I manage. It's []
    [reactionner] Sending us a configuration {'arbiters': {}, 'global': {'max_workers': 30, 'modules': [], 'reactionner_name': u'integ-reactionner', 'processes_by_worker': 256, 'passive': False, 'use_timezone': 'NOTSET', 'reactionner_tags': ['None'], 'polling_interval': 1, 'min_workers': 1, 'manage_arbiters': False}, 'schedulers': {0: {'instance_id': 0, 'active': True, 'address': u'localhost', 'port': 7768, 'name': u'integ-scheduler'}}}
    [integ-reactionner] Init de connection with integ-scheduler at PYROLOC://localhost:7768/Checks
    [integ-reactionner] Connection OK with scheduler integ-scheduler
    We have our schedulers : {0: {'wait_homerun': {}, 'name': u'integ-scheduler', 'uri': u'PYROLOC://localhost:7768/Checks', 'actions': {}, 'instance_id': 0, 'running_id': '1325145212.0', 'address': u'localhost', 'active': True, 'port': 7768, 'con': <DynamicProxy for PYRO://127.0.0.1:7768/0a01016f297d1eda7b20c22e0254a23c29>}}
    Warning in importing module : No module named redis
    Detected module : TSCA module for Arbiter/receiver
    Warning in importing module : No module named org.shinken_monitoring.tsca
    Warning in importing module : No module named ldap
    Warning in importing module : No module named MySQLdb
    Warning in importing module : No module named memcache
    Loaded Apache/Passwd module
    Loaded Apache/Passwd module
    Warning in importing module : No module named android
    Warning in importing module : No module named MySQLdb
    I am GlpiDB Broker
    Warning in importing module : No module named org.shinkenmonitoring.broker
    I correctly loaded the modules : []
    Loop turn
     ========================
    Wait ratio: 1
    [integ-reactionner] Allocating new fork Worker : 0
    Loop turn
     ========================
    [0][integ-scheduler][fork]Stats : Workers:0 (Queued:0 TotalReturnWait:0)
    Wait ratio: 1.0
    Loop turn
     ========================
    [0][integ-scheduler][fork]Stats : Workers:0 (Queued:0 TotalReturnWait:0)
    Wait ratio: 1.0
    Loop turn
     ========================
    [...]
     ========================
    [0][integ-scheduler][fork]Stats : Workers:0 (Queued:0 TotalReturnWait:0)
    Wait ratio: 1.0
    Ask actions to 0 got 0
    Loop turn
    1325147642 DBG: the arbiter ask me what I manage. It's [0]
     ========================
    [0][integ-scheduler][fork]Stats : Workers:0 (Queued:0 TotalReturnWait:0)
    Wait ratio: 1.0
    Ask actions to 0 got 0
    Loop turn
     ========================
    [0][integ-scheduler][fork]Stats : Workers:0 (Queued:0 TotalReturnWait:0)
    Wait ratio: 1.0
    Ask actions to 0 got 0
    Loop turn
     ========================
    [...]

  2. #2
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,131

    Re: Can't make shinken to send notifications

    Hi,

    Are there some "NOTIFICATION" lines in the schedulerd.log file?

    If there are some, the problem can be in the "[1325148446] Warning : 26 actions never came back for the satellite 'integ-reactionner'. I'm reenable them for polling", because it means that the reactionner never give back notification returns (and so maybe never launched them a all).

    Are ther some line like "Ask actions to 0 got 0" in the reactionner debug log, but with not "got 0" (means fots 0 notification to launch in fact) ? :
    No direct support by personal message. Please open a thread so everyone can see the solution

  3. #3

    Re: Can't make shinken to send notifications

    No, I don't have any NOTIFICATION line in the scheduler logs, even if I try to send forced broadcast notifications from thruk interface. I tried to remove my retention file between stop and start without success.

  4. #4

    Re: Can't make shinken to send notifications

    Found my problem, but I think there is a bug in config check code…

    The notification commands of my user omdadmin where bad, omd-dummy did'nt exist in my config. If I set it to the same value as my user lminoza, lminoza receive notifications, I can view SERVICE NOTIFICATION in the log and I did not view "Warning : * actions never came back for the satellite 'integ-reactionner'. I'm reenable them for polling".

    The bug is I think that without setting anything else than n for notification options the initial config check says that the config is OK. But the reactionner seams to reject the notifications…

  5. #5
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,131

    Re: Can't make shinken to send notifications

    Outch, strange one indeed

    In fact the "n" option is a bypass for command check, like in Nagios behavior in fact, and so it's normal that omdadmin don't raise notification (should be no command, no notification, but I must look deeper in the code to see if the scheduler/receiver are really ok on this point), but then why lminoza didn't receive notification too? :
    No direct support by personal message. Please open a thread so everyone can see the solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •