Results 1 to 6 of 6

Thread: [RESOLVED] no graph pnp4nagios displayed

  1. #1
    Junior Member
    Join Date
    Dec 2011
    Posts
    13

    [RESOLVED] no graph pnp4nagios displayed

    Hi,

    I've downloaded the GIT version of shinken to test with perf-o-meter and pnp4nagios integrated.

    pnp4nagios works fine ( it seems to be ... ) I have graphs, it runs on npcd mode

    Unfortunately, through the web interface of shinken, there is no link with the graph ( see capture.png )

    It runs on a RH6.1

    Here is an extract from shinken-specific.cfg

    If you have any suggestions because i can't find any error, you're welcome ;-)

    define broker{
    broker_name broker-1
    address localhost
    port 7772
    spare 0

    # Which modules to load? LiveSatus and logs by default.
    modules Status-Dat, Simple-log, WebUI, NPCDMOD

    define module{
    module_name NPCDMOD
    module_type npcdmod
    config_file /usr/local/pnp4nagios/etc/npcd.cfg
    }


    here is the npcd.cfg

    # NPCD.cfg - sample configuration file for PNPs NPCD
    #
    # Privilege Options

    user = shinken
    group = shinken

    # Logging Options #



    log_type = file
    #log_type = syslog



    log_file = /usr/local/pnp4nagios/var/npcd.log

    max_logfile_size = 10485760

    log_level = 1


    perfdata_spool_dir = /usr/local/pnp4nagios/var/spool/


    perfdata_file_run_cmd = /usr/local/pnp4nagios/libexec/process_perfdata.pl



    perfdata_file_run_cmd_args = -b


    identify_npcd = 1


    # npcd_max_threads - define how many parallel threads we
    # should start

    npcd_max_threads = 5

    # sleep_time - how many seconds npcd should wait between dirscans
    #
    # sleep_time = 15 (default)

    sleep_time = 15



    load_threshold = 0.0


    # location of your pid file

    pid_file=/var/run/npcd.pid



    perfdata_file = /usr/local/pnp4nagios/var/perfdata.dump



    perfdata_spool_filename = perfdata

    perfdata_file_processing_interval = 15

    # We have to end with a newline



    and here, the brokerd.log

    2011-12-21 09:00:36,694 [1324454436] Using the local log file 'brokerd.log'

    2011-12-21 09:00:36,711 [1324454436] Waiting for initial configuration

    2011-12-21 09:00:37,304 [1324454437] [broker-1] [broker-1] We have our schedulers : {0: {'broks': {}, 'last_connection': 0, 'name': u'scheduler-1', 'uri': u'PYROLOC://localhost:7768/Broks', 'instance_id': 0, 'running_id': 0, 'address': u'localhost', 'active': True, 'port': 7768}}

    2011-12-21 09:00:37,304 [1324454437] [broker-1] [broker-1] We have our arbiters : {0: {'broks': {}, 'last_connection': 0, 'name': u'Arbiter-Master', 'uri': u'PYROLOC://localhost:7770/Broks', 'instance_id': 0, 'running_id': 0, 'address': u'localhost', 'port': 7770}}

    2011-12-21 09:00:37,305 [1324454437] [broker-1] [broker-1] We have our pollers : {0: {'broks': {}, 'passive': False, 'last_connection': 0, 'name': u'poller-1', 'poller_tags': ['None'], 'uri': u'PYROLOC://localhost:7771/Broks', 'instance_id': 0, 'reactionner_tags': [], 'running_id': 0, 'address': u'localhost', 'active': True, 'port': 7771}}

    2011-12-21 09:00:37,305 [1324454437] [broker-1] [broker-1] We have our reactionners : {0: {'broks': {}, 'passive': False, 'last_connection': 0, 'name': u'reactionner-1', 'poller_tags': [], 'uri': u'PYROLOC://localhost:7769/Broks', 'instance_id': 0, 'reactionner_tags': ['None'], 'running_id': 0, 'address': u'localhost', 'active': True, 'port': 7769}}

    2011-12-21 09:00:37,305 [1324454437] [broker-1] [broker-1] We received modules [<shinken.objects.module.Module object at 0xec5110>, <shinken.objects.module.Module object at 0xec5250>, <shinken.objects.module.Module object at 0xec5290>, <shinken.objects.module.Module object at 0xec5390>, <shinken.objects.module.Module object at 0xec53d0>, <shinken.objects.module.Module object at 0xec5410>]

    2011-12-21 09:00:37,567 [1324454437] [broker-1] [broker-1] Connection OK to the scheduler scheduler-1

    2011-12-21 09:00:37,669 [1324454437] [broker-1] [broker-1] Connection OK to the poller poller-1

    2011-12-21 09:00:37,671 [1324454437] [broker-1] [broker-1] Connection OK to the reactionner reactionner-1

    2011-12-21 09:00:37,674 [1324454437] [broker-1] Warning in importing module : No module named android

    2011-12-21 09:00:37,690 [1324454437] [broker-1] Warning in importing module : No module named memcache

    2011-12-21 09:00:37,695 [1324454437] [broker-1] Warning in importing module : No module named org.shinken_monitoring.tsca

    2011-12-21 09:00:37,702 [1324454437] [broker-1] Warning in importing module : No module named ldap

    2011-12-21 09:00:37,706 [1324454437] [broker-1] Warning in importing module : No module named redis

    2011-12-21 09:00:37,720 [1324454437] [broker-1] Warning in importing module : No module named org.shinkenmonitoring.broker

    2011-12-21 09:00:37,735 [1324454437] [broker-1] Trying to init module : Simple-log

    2011-12-21 09:00:37,735 [1324454437] [broker-1] I open the log file /var/log/shinken/nagios.log

    2011-12-21 09:00:37,735 [1324454437] [broker-1] Trying to init module : Service-Perfdata-Autogenerated

    2011-12-21 09:00:37,735 [1324454437] [broker-1] Trying to init module : Host-Perfdata-Autogenerated

    2011-12-21 09:00:37,735 [1324454437] [broker-1] I correctly loaded the modules : [Status-Dat,Simple-log,WebUI,NPCDMOD,Service-Perfdata-Autogenerated,Host-Perfdata-Autogenerated]

    2011-12-21 09:00:37,736 [1324454437] [broker-1] Trying to init module : Status-Dat

    2011-12-21 09:00:37,740 [1324454437] [broker-1] Starting external module Status-Dat

    2011-12-21 09:00:37,740 [1324454437] [broker-1] Starting external process for instance Status-Dat

    2011-12-21 09:00:37,742 [1324454437] [broker-1] Status-Dat is now started ; pid=26282

    2011-12-21 09:00:37,742 [1324454437] [broker-1] Trying to init module : WebUI

    2011-12-21 09:00:37,749 [1324454437] [broker-1] Starting external module WebUI

    2011-12-21 09:00:37,749 [1324454437] [broker-1] Starting external process for instance WebUI

    2011-12-21 09:00:37,750 [1324454437] [broker-1] WebUI is now started ; pid=26292

    2011-12-21 09:00:37,751 [1324454437] [broker-1] Trying to init module : NPCDMOD

    2011-12-21 09:00:37,759 [1324454437] Warning in importing module : No module named android

    2011-12-21 09:00:37,760 [1324454437] Warning in importing module : No module named memcache

    2011-12-21 09:00:37,760 [1324454437] Warning in importing module : No module named org.shinken_monitoring.tsca

    2011-12-21 09:00:37,761 [1324454437] Warning in importing module : No module named ldap

    2011-12-21 09:00:37,762 [1324454437] [broker-1] Starting external module NPCDMOD

    2011-12-21 09:00:37,762 [1324454437] [broker-1] Starting external process for instance NPCDMOD

    2011-12-21 09:00:37,763 [1324454437] [broker-1] NPCDMOD is now started ; pid=26303

    2011-12-21 09:00:37,762 [1324454437] Warning in importing module : No module named redis

    2011-12-21 09:00:37,765 [1324454437] Warning in importing module : No module named org.shinkenmonitoring.broker

    2011-12-21 09:00:37,766 [1324454437] Warning : the module type ad_webui for ActiveDir_UI was not found in modules!

    2011-12-21 09:00:37,766 [1324454437] Trying to init module : Cfg_password

    2011-12-21 09:00:37,766 [1324454437] Trying to init module : Apache_passwd

    2011-12-21 09:00:37,766 [1324454437] I correctly loaded the modules : [Cfg_password,Apache_passwd]

  2. #2
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,131

    Re: no graph pnp4nagios displayed

    Did you activate the PNP_UI module for the WebUI one? (the npcd one write data, the pnp_ui allow to see graphs in the module, we are working in a configuration UI taht will allow to add both in the same action )
    No direct support by personal message. Please open a thread so everyone can see the solution

  3. #3
    Junior Member
    Join Date
    Dec 2011
    Posts
    13

    Re: no graph pnp4nagios displayed

    mmmh, a hidden settings ?? ;-)

    We test this version for now : naparuba-shinken-0.8.5-10-gfa7f40c

    I've added just now in shinken-specific.cfg this :

    define module{
    module_name WebUI
    module_type webui

    host 0.0.0.0 ; mean all interfaces
    port 7767

    # CHANGE THIS VALUE or someone can forge cookies !!!!!!!
    auth_secret xxxxxxxxxxxxx

    # Uncomment to present a text in the login form
    # login_text Welcome on Shinken WebUI.

    # Advanced options. Do not touch it if you don't
    # know what you are doing

    #http_backend auto
    # ; can be also : wsgiref, cherrypy, paste, tornado, twisted
    # ; or gevent

    modules Apache_passwd,ActiveDir_UI,Cfg_password,PNP_UI
    # Modules for the WebUI.

    }


    I found nothing in any log file

  4. #4
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,131

    Re: no graph pnp4nagios displayed

    The 0.8.5 should have this PNP_UI module. If it's an update, your shinken-specific.cfg is keep, and so it's not defined. It look like :

    Code:
    # Use PNP graphs in the WebUI
    define module{
     module_name PNP_UI
     module_type pnp_webui
     uri     http://YOURSERVERNAME/pnp4nagios/  ; put the real PNP uri here. YOURSERVERNAME will be changed
                           ; bu the localname of the server
    
    }
    No direct support by personal message. Please open a thread so everyone can see the solution

  5. #5
    Junior Member
    Join Date
    Dec 2011
    Posts
    13

    Re: no graph pnp4nagios displayed

    damn........

    changed and .... Great !! Thank you for all informations, it works now

    I still have a little problem but .... it will be to another thread


  6. #6
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,131

    Re: no graph pnp4nagios displayed

    Great ;D
    No direct support by personal message. Please open a thread so everyone can see the solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •