Results 1 to 7 of 7

Thread: I have no graphs for some services

  1. #1
    Junior Member
    Join Date
    Mar 2014
    Posts
    4

    I have no graphs for some services

    Deer Shinkers,

    This is my setup:
    - CentOS 6.4
    - Shinken + PNP4Nagios + Thruk from OMD 1.10

    I have 20 hosts with nearly the same services.
    I've changed the name of 2 of them, and I have graph data for all the services belonging to these hosts in var/pnp4nagios/perfdata.

    For the other hosts, many services don't have neither .rrd nor .xml file in var/pnp4nagios/perfdata/hostname
    even though the command produces performance data. I don't understand why.

    In my templates, I have defined an action_url for a service and for a host.

    Any idea please?
    Can I reset the state of pnp4nagios?
    I've tried to remove the content of the var/pnp4nagios/perfdata folder with no success.

  2. #2
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: I have no graphs for some services

    Is the enable_perfdata parameter is on on theses services? Try to drop your retention data and restart shinken.
    No direct support by personal message. Please open a thread so everyone can see the solution

  3. #3
    Junior Member
    Join Date
    Mar 2014
    Posts
    4

    Re: I have no graphs for some services

    Thanks Naparuba,

    Yes process_perf_data = 1 in my service template.
    How can I drop retention data?

    [quote author=naparuba link=topic=1650.msg6802#msg6802 date=1393851804]
    Is the enable_perfdata parameter is on on theses services? Try to drop your retention data and restart shinken.
    [/quote]

  4. #4
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: I have no graphs for some services

    what is your retention module?
    No direct support by personal message. Please open a thread so everyone can see the solution

  5. #5
    Junior Member
    Join Date
    Mar 2014
    Posts
    4

    Re: I have no graphs for some services

    $ cat shinken-specific.d/module_nagios_retention.cfg
    define module{
    module_name NagiosRetention
    module_type nagios_retention_file
    path /omd/sites/pro/var/nagios/retention.dat
    }

    #Now the good flat file retention module
    define module{
    module_name PickleRetention
    module_type pickle_retention_file
    path /omd/sites/pro/var/shinken/retention.dat
    }

    So, I'll try to delete /omd/sites/pro/var/shinken/retention.dat

    After having read this, I've come to the conclusion that I use the pickle retention module.

    [quote author=naparuba link=topic=1650.msg6807#msg6807 date=1393917693]
    what is your retention module?
    [/quote]

  6. #6
    Junior Member
    Join Date
    Mar 2014
    Posts
    4

    Re: I have no graphs for some services

    It seems that deleting that file is magical. ;D
    Now, a lot of new .rrd files are being created.
    It would be worth to place this in the FAQ.
    It's been hard to discover this.

  7. #7
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,130

    Re: I have no graphs for some services

    Not need, this was fixed in the incomming 2.0, this parameter won't be load from retention now
    No direct support by personal message. Please open a thread so everyone can see the solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •