Results 1 to 2 of 2

Thread: service notification_interval attribute does not seem to be used ...

  1. #1
    Member
    Join Date
    May 2013
    Location
    France - Valence
    Posts
    91

    service notification_interval attribute does not seem to be used ...

    Hi,
    I have a strange behaviour with notification interval. One of my passively checked service is in WARNING state and I receive mail notifications every 5 minutes whereas I should receive every 2 hours (notification_interval = 240).

    When I look at the service notification_interval in Shinken WebUI (I made a patch to view ...), I get 240. But when I look at service configuration in Thruk, I get 0 ...

    I do not understand two things :
    - why do Shinken and Thruk not "see" the same value ?
    - why do I get mail every 5 minutes whereas I configured 240 minutes. I tried to change from 240 to any other value but it does not change anything ...


    Edit :
    Perharps is_volatile=1 is not innocent because everything seems ok with notifications when is_volatile=0


    BR, Fred.


    I copy my Thruk service configuration view below :

    [tt]
    Description Max. Check Attempts Normal Check Interval Retry Check Interal Check Command Check Period Enable Active Checks Enable Passive Checks Enable Notifications Notification Interval First Notification Delay Notification Period
    nsca_disk 1 0h 0m 0s 0h 0m 0s check_dummy!2!No data for disk 24x7 No Yes Yes 0h 0m 0s 0h 0m 0s 24x7
    [/tt]


    I copy my Shinken configuration below :

    [tt]
    define contact{
    contact_name monitoring
    alias Monitoring
    host_notifications_enabled 1
    service_notifications_enabled 1
    service_notification_period 24x7
    host_notification_period 24x7
    service_notification_options w,u,c,r,f
    host_notification_options d,u,r,f,s
    service_notification_commands nagios_send_host_mail
    host_notification_commands notify-host-by-email
    email frederic.mohier@shinken.com
    pager
    }


    define service{
    use template4-service
    host_name fvc318
    service_description nsca_disk
    check_freshness 1
    freshness_threshold 3600
    check_command check_dummy!2!No data for disk
    contacts monitoring
    notification_period 24x7
    notification_interval 240
    }


    define service{
    name template4-service
    check_interval 60
    retry_interval 1
    max_check_attempts 1
    check_period 24x7
    notification_interval 30
    notification_period 24x7
    notification_options w,u,c,r,f,s
    process_perf_data 1
    active_checks_enabled 0
    passive_checks_enabled 1
    parallelize_check 1
    obsess_over_service 1
    check_freshness 1
    freshness_threshold 3600
    notifications_enabled 1
    event_handler_enabled 0
    flap_detection_enabled 1
    failure_prediction_enabled 1
    retain_status_information 1
    retain_nonstatus_information 1
    is_volatile 1
    _httpstink NO
    register 0
    }

    [/tt]

  2. #2
    Shinken project leader
    Join Date
    May 2011
    Location
    Bordeaux (France)
    Posts
    2,131

    Re: service notification_interval attribute does not seem to be used ...

    Thruk is LiveStatus based, WebUI is not. So the problem of the parameter can be in not being implemented into Livestatus.

    For the behavior, yes, the volative is done for this behavior (alert=notification). Just remove it
    No direct support by personal message. Please open a thread so everyone can see the solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •